Tag Archives: .net

How to make that all references to olds assemblies point to a specif assembly

Hi,

Some tips about assembly issues. Microsoft provide us of one way to fix some issues related to references of assemblies when we have several version referenced by our projects (DLLs). In this example, I show you how to do that references to System.Web.Extensions use the latest version (3.5) instead the old version. When we found this issues? R. When we have several projects which apoint to several version of same assembly.

For instance, I got this message:
The base class includes the field ‘UpdatePanel1’, but its type (System.Web.UI.UpdatePanel) is not compatible with the type of control (System.Web.UI.UpdatePanel)

and the reason was that I referenced to 1.X and 3.x version of same assembly. Other message of error was this one, despite that I had installed the assembly but with a newer version:

Could not load file or assembly ‘AjaxControlToolkit, Version=1.0.20229.20821

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;" />
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>

Best regards,

I hope that avoid you some hours of headache

Álvaro Brange

Advertisements